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1 Introduction

A cellular  automata  is  a  lattice  of  cells  which  are  used  as  both  memory  and  processing
elements. This lattice of cells can exist in any dimension and can be of infinite size. At any
given time each cell can be in one of any of a finite number of states. The transitions between
states from one time step to the next (from one iteration to the next) depends upon the state of
the cell and the neighbouring cells states. Each state is defined by clear rules, and these rules
apply to all the cells on the lattice and at all times. The configuration of cells in the next time
step is determined entirely by the current arrangement of cells – past arrangements have no
direct influence over future cell arrangements.

Perhaps the most famous cellular automata was developed by John Conway. In Conway’s
“Life”, which is played in an infinite two–dimensional board where each cell is a square (and
therefore has eight neighbouring squares). There exist only two possible cell states – on (or
“alive”) and off (or “dead”). The rules are very simple: if a cell is off it remains off in the next
time step unless there are exactly three neighbouring cells in the on state, if a cell is on it
remains on unless there are more than three “on” neighbours or if there are less than two “on”
neighbours. The patterns produced from these simple rules are amazing, with many “life–like”
structures emerging (such as “gliders” which “walk” diagonally across the board).

Tresvita is very similar in idea to Conway’s “Life”. In Tresvita there exist only two possible cell
states,  “alive” and “dead”,  and the rule sets are defined in  a very similar way. The major
difference is that Tresvita is a three dimensional cellular automata.

2 Loading Tresvita

Tresvita  is  a  FAT application.  This  means  that  it  runs  on  both  traditional  68K  Macintosh
computers and also on the newer Power Macintosh (PPC) computers. When running on a
PPC machine it takes advantage of the more powerful features available and so should run
considerably faster than on standard 68K Macs.

Tresvita requires a minimum of System 7.0 to run. If you are running Tresvita using a version
of the system software older than System 7.5 you will  need to install  the Thread Manager
extension available free from many sources.

The minimum amount of free memory needed to safely run Tresvita is 1Mb, but I suggest 2Mb
if you want to run several large “growths” at once.



3 The Program

3.a Starting a New Growth

First load Tresvita (if you have not already done so) by double–clicking on the application’s
icon. To start a new growth select New from the File menu (or press command–N). A dialog
box will appear.

When you are satisfied with the settings in the dialog box click on the  OK button (or press
return) to start the growth. Press the Cancel button to cancel.

3.a.i Setting the Rule–Set

The four text boxes display the current rule set (in the picture above they contain the numbers
“4”, “5”, “5” and “5”). You can change these values by either typing in a new number or using
the arrows to the left of the text box.

What do these values mean? In Conway’s “Life” there were only two dimensions, so each cell
only had eight neighbours, however in Tresvita there are three dimensions. This means that
each cell has 26 neighbouring cells.



The eight neighbours 
in Conway’s “Life”

The 26 neighbours in 
“Tresvita”

The numbers in the four text boxes allow you to customise the rule set that will be used. You
can enter a maximum value of 26, and an minimum value of 0. There are basically two sets of
rules to define – the 



number of neighbours a cell needs to survive, and how many neighbouring cells are needed
for growth. The text boxes allows you to define the minimum and maximum values for each.

For example, if you wanted to set the rules so that the values were the same as those for
Conway’s “Life” you would set the values as follows:

Neighbours Needed 
for Growth
MaximumMinimumNeighbours Needed 
for Survival
MaximumMinimum3233

This setup is exactly the same as the rules described for “Life” but don’t forget that these
values  probably  won’t  yield  interesting  results  since  the  rules  were  devised  for  a  two
dimensional board where there are only eight neighbours, now we are dealing with a three
dimensional board with 26 neighbours.

3.a.ii Selecting a Grid Size

Tresvita also lets you change the size of the grid the growth is ran on. Although a cellular
automata is ideally ran on an infinite sized grid this is impractical using a modern computer. In
the picture of the dialog box above the grid size is set to 10x10x10 – the number of cells along
the x axis is 10, the number along the y axis is 10, and the number along the z axis is 10.

The size of the grid can be easily changed. Hold down on the pop–up menu  and you can
select one of a number of pre–defined grid sizes.

3.a.iii Selecting a Custom Grid Size

By selecting “Other...” from the pop–up menu you can enter a customised grid size. Please
note that the maximum value for each dimension is 100, and the minimum is 1.



The “Other...” dialog box. 
Press the return key or click on 
the “OK” button when you are 
finished.



3.a.iv The Rule–Set’s Lambda Value

The bottom left hand corner of the “New” dialog box shows the rule set’s lambda value. This
number represents the degree of information movement and retention on a 0 to 1 scale. The
lambda value depends solely upon the rule set chosen. If the lambda value is very low then
information (ie. the state of cells on the grid) is static; it is easily retained through time, but
moves little. On the other hand a high lambda value represents a chaotic regime. Information
is moved freely, but retaining it is difficult. However there is a certain point in between where
complexity runs riot. Conway's "Life" has a lambda value of 0.273.

3.a.v Saving a Movie

The “Save Movie” check box allows you to save a movie of your growth to disk. This movie is
saved in Apple QuickTime format,  and is supported by many applications. This is a useful
feature for very large grids or for growths which run over a long period of time.

3.a.vi The Text Report

The “Save Report” check box allows you to save a simple text report about the growth. A text
report will record the rule set, the size of the grid and the lambda value. Also the population
size and probability of a change in state will be recorded. The text report can be easily copied
and pasted into a spreadsheet program so accurate graphs can be plotted.

The text report  is always arranged in the same way, with lines added to the bottom each
iteration concerning the population size and probability of a change in state.



Grid X: 10
Grid Y: 10
Grid Z: 10

Min Survival: 4
Max Survival: 5
Min Repro: 5
Max Repro: 5

Lambda Value: 0.00109

Population State Change
158 0.235
195 0.248
165 0.210
175 0.233
150 0.180

The size of 
the grid

The rule 
set used

The lambda vale of 
the rule set

Information 
recorded each 

iteration



3.b The Windows

3.b.i The Growth Window

When you run a Tresvita growth, the window is arranged as bellow.

Horizontal Scroll BarVertical 
Scroll Bar
Grow BoxResize 

Box
Close BoxGrowth TitleThe Tresvita 

Growth
Play/Pause 

Button
Iteration Counter

The window behaves like a normal Macintosh window, with scroll bars, a title bar and so on.
The only non–standard parts of the window are the iteration counter, the play/pause button and
the actual Tresvita growth displayed in the window.

The growth shown in the window is draw to the current render mode and is updated each
iteration. A Tresvita growth is drawn as a 3–dimensional shape with the viewer looking down
upon the shape from the top left hand side of the growth.

The iteration counter displays the current iteration. When a new growth is started, or a file
opened, the iteration counter reads 0.

The play/pause button allows the calculation on the growth to be paused or started. When a
new window is opened the growth will  be in the paused state. Clicking once on the “play”
button ( ) will start the growth running, and the iteration counter will start counting. The
play button will change to a “pause” button ( ). Clicking on the pause button will stop all
calculation on the growth once the current iteration has been computed.



3.b.ii The Population Window

To display the population window for the front–most growth (ie. the currently active window)
choose Show Population Graph from the Grid menu. This will display the population window.

To hide the population window either click on its close box, or select Hide Population Graph
from the Grid menu.

The population window shows a simple bar graph of the growth population over the past 100
iterations. At the top of the window (underneath the title bar) the title of the corresponding
growth window is displayed.

The  graph  is  useful  when  identifying  patterns  in  a  growth,  looking  for  blinkers,  or  when
attempting to find long term population trends.

N.B. For a more accurate population graph use the “Save Report” feature in the New dialog
and plot a graph using a spread sheet program.

3.b.iii The Rule–Set Window

To display the rule–set window for the front–most  growth (ie.  the currently active window)
choose Show Rule–Set from the Grid menu. This will display the rule–set window.

To hide the rule–set window either click on its close box, or select  Hide Rule–Set from the
Grid menu.

The rule–set window is very simple. It  displays the rule–set for the growth, as well  as the
lambda value (to 5 decimal places). At the top of the window the title of the corresponding
growth window is displayed.



3.b.iii The State Change Window

To display  the  probability  of  a  change in  state  window for  the  front–most  growth  (ie.  the
currently active window) choose  Show State Change from the  Grid menu. This will display
the state change window.

To hide the state change window either click on its close box, or select  Hide State Change
from the Grid menu.

The state change window shows what the probability of any cell on the grid changing its state
during the last iteration was. A change in state is when an “alive” cell “dies”, or when an empty
cell becomes “alive”. A probability of 1 indicates no similarities between the current iteration
and the previous one, a probability of 0 indicates a stable pattern. The overall rate of change of
the grid increases from static to random and can be used to judge whether a growth has
become predictable or not. At the top of the window (underneath the title bar) the title of the
corresponding growth window is displayed.

N.B. For a more accurate view of the probability of change of state use the “Save Report”
feature in the New dialog and plot a graph using a separate spread sheet program.



3.c The Grid Editor

It is often necessary to “seed” a grid with a simple pattern, and often interesting to watch a
pattern of cells you arranged grow and change under the influence of the rule set. You can edit
the arrangement of cells in a grid by selecting Edit Grid from the Grid menu. This will display
a dialog box enabling you to add and remove cells to the currently selected window’s grid.

The interface for the grid editor is relatively straight forwards, however there are a few features
which need pointing out.

The  grid  editor  contains  three  scroll  bars.  Two are  for  the  normal  horizontal  and  vertical
scrolling (the two inactive scroll bars in the image above). The third scroll bar (positioned to the
left) allows scrolling through the ‘z’ axis of the grid. How does this work? Image the grid is a
series of cards in a filing system. By using the ‘z’ scroll bar we can select anyone of the cards
to work on, then the card is inserted back into the filing system; back into the correct ‘z’ axis
position.  By moving though the ‘z’ axis layer by layer  you can build up quite complicated
shapes.



The numbers displayed in the top right hand corner of the grid editor show the current z–axis
position, as well as showing the cursor’s position in the x and y axes. In the screen shot above
the mouse cursor is over the the cells matching co–ordinates (4, 2, 6) in the grid.

By clicking over an “alive” cell (yellow) you can turn that individual cell off, or by clicking and
dragging turn a number of cells off. By clicking over a "dead" cell you can turn it on (“alive”) or,
by clicking and dragging, turn a number of cells on.

Clicking on the Clear button will turn off every cell in the grid.

Clicking on the  Save As... button will save the grid you have designed to disk, but will not
effect the file currently being used. This allows you to design a number of different grids easily
within the grid designer without changing the currently open grid.

When you are finished click on OK to put the changes you have made into effect, or click on
Cancel to ignore any changes you have made to the grid's cells.



3.d The Render Menu

The Render menu allows the user to change the way Tresvita displays the grid. All changes to
the Render menu take place on the currently selected window. The default render settings are
Depth  Render switched  on,  Display  Grid switched  off  and  the  Solid  Cell render  mode
selected.

The Render menu is divided into two parts separated by a separator line. The top part has two
render options that apply to any render mode. These are  Depth Render and  Display Grid.
Their effects are shown bellow (the  Solid Cell render mode is being used, but the effects
would be the same whatever the mode).

Solid CellDepth Render
Solid Cell

Display Grid
Depth Render

Solid Cell

The second part of the Render menu consists of a variety of drawing modes. These are Wire
Frame, Front Face, Fuzzy Cell, Solid Cell, and Solid Object. Only one of these modes can
be selected at a time. Their effects are shown below.

Solid ObjectSolid CellWire FrameFront FaceFuzzy Cell

3.e The Edit Menu

The Edit menu is used little in Tresvita.

By choosing Copy the data being displayed in the currently selected window will be copied to
the clipboard for later pasting into another application. This allows the user to copy the image
of the cell growth and paste it into a document with ease.



No other Edit menu items are currently supported.



3.f The File Menu

The File menu contains all the items you would expect in a Macintosh application (the only
exception being the omission of a Print option).

Selecting New will open a dialog box allowing you to set the rule set, grid size etc. for a new
Tresvita growth. This menu item is disabled if there are already 10 growths running, since
Tresvita can not handle more than 10 growths at a time.

Selecting Open... allows you to select a file to view. This can be a Tresvita growth previously
saved to disk, or it can be a QuickTime movie. This file will be disabled if there are already 10
growths running, since Tresvita can not handle more than 10 growths (including QuickTime
movies) at a time.

Selecting  Close will  close  the  front  window.  If  no  windows  are  open,  this  menu  item  is
disabled.

Save will  save any changes you have made to the currently open file.  If  you have made
changes to a new Tresvita file (ie. one created with the New... item rather than a file that has
been opened) this item will behave like the Save As... item. This item is disabled if no windows
are open.

Save As... will save the current growth as a new file. Any later calls to Save will update this
saved file. This item is disabled if no windows are open.

Quit exits Tresvita. You will be asked whether you want to save changes any open files.
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